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Named Ranges 
You can use the labels of columns and rows on a worksheet to refer to the cells within those 
columns and rows. Or you can create descriptive names to represent cells, ranges of cells, 
formulas, or constant values. Labels can be used in formulas that refer to data on the same 
worksheet; if you want to represent a range on another worksheet, use a name. 

You can also create 3-D names that represent the same cell or range of cells across multiple 
worksheets. 

Guidelines for Names 
• The first character of a name must be a letter, an underscore character (_), or a 

backslash (\). The remaining characters in the name can be letters, numbers, periods, 
and underscore characters. 

• Names cannot be the same as a cell reference, such as Z$100 or R1C1. 
• You can use multiple words in a name, but spaces are not allowed. Underscore 

characters and periods may be used as word separators — for example, Sales_Tax or 
First.Quarter. 

• A name can contain up to 255 characters. If a name defined for a range contains more 
than 253 characters, you cannot select it from the Name box. 

• Names can contain uppercase and lowercase letters. Microsoft Excel does not 
distinguish between uppercase and lowercase characters in names. For example, if 
you have created the name Sales and then create another name called SALES in the 
same workbook, the second name will replace the first one. 

Name Manager – Use the Name Manager to create, edit, and delete range names.  The Name 
Manager provides a complete list of range names in the workbook. 

To Name a Range 
1. Select the cell or range of cells.  
2. Click in the name box. 
3. Type the name. 
4. Press Enter 

Edit or Delete Named Ranges 
Use the Name Manager to create, edit, and delete range names.   

• From the Formulas Tab, in the Defined Names Group, click on Name Manager. 
• Select the named range you want to modify. 
• Make the necessary changes then close when finished. 
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If Functions 
The IF function is one of the most popular functions in Excel, and it allows you to make logical 
comparisons between a value and what you expect. 

IF Function - Syntax and Usage 
The IF function is one of Excel's logical functions that evaluates a certain condition and returns 
the value you specify if the condition is TRUE, and another value if the condition is FALSE. 

The syntax for Excel IF is as follows: IF(logical_test, [value_if_true], [value_if_false])  

As you see, the IF function has 3 arguments, but only the first one is obligatory, the other two 
are optional. 

logical_test - a value or logical expression that can be either TRUE or FALSE. Required. In this 
argument, you can specify a text value, date, number, or any comparison operator. For 
example, your logical test can be expressed as or B1="sold", B1<12/1/2014, B1=10 or B1>10. 

value_if_true - the value to return when the logical test evaluates to TRUE, i.e. if the condition 
is met. Optional. For example, the following formula will return the text "Good" if a value in cell 
B1 is greater than 10: =IF(B1>10, "Good") 

value_if_false - the value to be returned if the logical test evaluates to FALSE, i.e. if the 
condition is not met. Optional. So, an IF statement can have two results. The first result is if your 
comparison is True, the second if your comparison is False. For example, =IF(C2=”Yes”,1,2) 
says IF(C2 = Yes, then return a 1, otherwise return a 2).If you need to apply more than one 
criteria, use the SUMIFS function. 

SumIF Function 
The SUMIF function is a worksheet function that adds all numbers in a range of cells 
based on one criteria (for example, is equal to 2000). 
The SUMIF function is a built-in function in Excel that is 
categorized as a Math/Trig Function. As a worksheet 
function, the SUMIF function can be entered as part of a 
formula in a cell of a worksheet. To add numbers in a range based on multiple criteria, 
try the SUMIFS function. 
 
=SUMIF(range, criteria, [sum_range]) 

• The range parameter is actually the range of cells that will be evaluated by the 
‘criteria’ parameter. 

• The criteria parameter is the condition that must be met in the range parameter. For 
instance, if our range was a column that listed t-shirt color, a value like red or white 
could be our criteria. The criteria value can be text, a number, a date, a logical 
expression, a cell reference, or even another function. 
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• The sum_range parameter is optional as noted by the brackets. This simply means 
that if omitted, the sum_range will default to the same cells you chose for the ‘range’ 
parameter.  

CountIF Function 
The Excel COUNTIF function in the Excel table determines the number of items, based on the 
criterion we provide. The function can be used, as an example, for determining the quantity of 
supplies, stocktaking, etc. The manual assumes that we have basic knowledge of creating 
formulas in Excel. 

Use COUNTIF, one of the statistical functions, to count the number of cells that meet a criterion; 
for example, to count the number of times a particular city appears in a customer list. 
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=COUNTIF(Where do you want to look?, What do you want to look for?) Syntax 
=COUNTIF(range, criteria)  

AverageIF Function 
AVERAGEIF calculates central tendency, which is the location of the center of a group of 
numbers in a statistical distribution. Returns the average (arithmetic mean) of all the cells in a 
range that meet a given criteria. Syntax =AVERAGEIF(range, criteria, [average_range]) 

Flash Fill 
Flash Fill is like a data assistant that finishes your work for you. As soon as it detects what you 
want to do, Flash Fill enters the rest of your data in one fell swoop, following the pattern it 
recognizes in your data. 

Here’s in an example: 

1. You have a long list containing huge amounts of data. For example, let’s says it’s the names 
of your customers and their seven-digit phone numbers shown in the Home Number column. If 
you need to make a couple of new columns out of this data, you can use Flash Fill. If you need 
to change the format of each phone number to 395-6492 instead 
of 3956492, inserting a hyphen in every phone number by typing 
is a lot of work. In previous versions of Excel, you could use a 
formula for that. However, Excel 2013 offers an even quicker 
way of doing it by using Flash Fill. 

Type the right format of the first phone number in a new 
column (e.g. 395-6492). Go to the next cell of the column 
and start typing the next phone number. After typing the 
first three digits (722).  

Excel will fill in the format you need for the rest of the 
phone numbers. All you need to do is just press enter, 
and you will get all phone numbers with a hyphen in that 
column. 

Lookup Functions 
vLookup 
The V in VLOOKUP stands for "Vertical." In Excel, the VLookup function searches for 
value in the left-most column of table_array and returns the value in the same row 
based on the index_number. 
 
Usually lists like this have some sort of unique identifier for each item in the list.  In this 
case, the unique identifier is in the “Item Code” column.  Note:  For the VLOOKUP 
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function to work with a database/list, that list must have a column containing the unique 
identifier (or “key”, or “ID”), and that column must be the first column in the table.  Our 
sample database above satisfies this criterion. 
 
The secret to VLOOKUP is to organize your data so that the value you look up is to the 
left of the return value you want to find. 
 
The VLOOKUP function syntax has the following arguments: 

VLOOKUP (lookup_value, table_array, col_index_num, [range_lookup]) 
 
For example: 

=VLOOKUP(105,A2:C7,2,TRUE) 
=VLOOKUP("Fontana",B2:E7,2,FALSE) 

 
lookup_value    (required) 

• The value you want to look up. The value 
you want to look up must be in the first 
column of the range of cells you specify 
in table-array. 

• For example, if table-array spans cells B2:D7, then your lookup_value must be in 
column B. See the graphic below. Lookup_value can be a value or a reference to 
a cell. 

 table_array    (required) 
• The range of cells in which the VLOOKUP will search for the lookup_value and 

the return value.  
• The first column in the cell range must contain the lookup_value (for example, 

Last Name in the picture below.) The cell range also needs to include the return 
value (for example, First Name in the graphic below) you want to find. 

col_index_num    (required) 
• The column number (starting with 1 for the left-most column of table-array) that 

contains the return value.  
range_lookup   (optional) 

• A logical value that specifies whether you want VLOOKUP to find an exact match 
or an approximate match: 

• TRUE assumes the first column in the table is sorted either numerically or 
alphabetically, and will then search for the closest value. This is the default 
method if you don't specify one. 

• FALSE searches for the exact value in the first column.  
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XLookup 
The XLOOKUP function searches a range or an array, and then returns the 
item corresponding to the first match it finds. If no match exists, then XLOOKUP can return 
the closest (approximate) match.  

=XLOOKUP(lookup_value, lookup_array, return_array, [if_not_found], 
[match_mode], [search_mode])  

Argument Description 
lookup_value 
Required* 

The value to search for 
 
*If omitted, XLOOKUP returns blank cells it finds in lookup_array.    

lookup_array 
Required 

The array or range to search 

return_array 
Required 

The array or range to return 

[if_not_found] 
Optional 

Where a valid match is not found, return the [if_not_found] text you 
supply. 
If a valid match is not found, and [if_not_found] is missing, #N/A is 
returned. 

[match_mode] 
Optional 

Specify the match type: 
0 - Exact match. If none found, return #N/A. This is the default. 
-1 - Exact match. If none found, return the next smaller item. 
1 - Exact match. If none found, return the next larger item. 
2 - A wildcard match where *, ?, and ~ have special meaning. 

[search_mode] 
Optional 

Specify the search mode to use: 
1 - Perform a search starting at the first item. This is the default. 
-1 - Perform a reverse search starting at the last item. 
2 - Perform a binary search that relies on lookup_array being sorted 
in ascending order. If not sorted, invalid results will be returned. 
-2 - Perform a binary search that relies on lookup_array being sorted 
in descending order. If not sorted, invalid results will be returned. 

https://support.microsoft.com/en-us/office/using-wildcard-characters-in-searches-ef94362e-9999-4350-ad74-4d2371110adb
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Examples 
Example 1    uses XLOOKUP to look 
up a country name in a range, and 
then return its telephone country 
code. It includes 
the lookup_value (cell 
F2), lookup_array (range B2:B11), 
and return_array (range D2:D11) 
arguments. It doesn't include 
the match_mode argument, as 
XLOOKUP produces an exact match 
by default. 

Note: XLOOKUP uses a lookup 
array and a return array, whereas VLOOKUP uses a single table array followed by a column 
index number. The equivalent VLOOKUP formula in this case would 
be: =VLOOKUP(F2,B2:D11,3,FALSE) 

Example 2    looks up 
employee information 
based on an employee 
ID number. Unlike 
VLOOKUP, XLOOKUP 
can return an array with 
multiple items, so a 
single formula can 
return both employee 
name and department 
from cells C5:D14. 
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Example 3    adds 
an if_not_found argument 
to the preceding example. 

Both formulas will return the 
same result. Notice, 
however, for XLOOKUP we 
provided both the lookup 
column and the result 
column separately. While for 
VLOOKUP we needed to 
provide the whole table and 
indicate the result column 
number. The additional 
difference we see is that in 
XLOOKUP we didn’t have to 
provide the exact match 
parameter – in XLOOKUP 
the default is an exact 
match. 

This makes the XLOOKUP function a combination of INDEX & MATCH functions. The 
VLOOKUP had a lot of issues like having to put the lookup column at the front of the table or at 
least before the result column. 

Using Excel Tables 
To make managing and analyzing a group of related data easier, you can turn a range 
of cells into a Microsoft Excel table (previously known as an Excel list). A table typically 
contains related data in a series of worksheet rows and columns that have been 
formatted as a table. By using the table features, you can then manage the data in the 
table rows and columns independently from the data in other 
rows and columns on the worksheet. 
 
Note:   Excel tables should not be confused with the data 
tables (data table: A range of cells that shows the results of 
substituting different values in one or more formulas. There 
are two types of data tables: one-input tables and two-input 
tables.) that are part of a suite of what-if analysis commands.  
 
To Apply a Table: 

1. Click inside the data range. 
2. From the Home Tab in the Styles Group click on Format as Table. 
3. Click on one of the preformatted options. 
4. Use the Table Tools to make changes to the Table. 

javascript:AppendPopup(this,'xldefRange_1')
javascript:AppendPopup(this,'xldefWorksheet_2')
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Sorting and filtering  
Filter drop-down lists (drop-down list box: A control on a menu, toolbar, or dialog box that displays a list 
of  options when you click the small arrow next to the list box.) are automatically added in the header 
row of a table. You can sort tables in ascending or descending order or by color, or you can 
create a custom sort order. You can filter tables to show only the data that meets the criteria 
that you specify, or you can filter by color.  

Formatting table data   
You can quickly format table data by applying a predefined or custom table style. You can also 
choose Table Styles options to display a table with or without a header or a totals row, to apply 
row or column banding to make a table easier to read, or to distinguish between the first or last 
columns and other columns in the table.  

Remove a Table 
If you chose to remove the Table features from a range of data you can do so by: 

1. Select the table 

2. From the Design tab in the Tools Group, click on . 

Sorting and Filtering Data 
You might want to put a list of names in alphabetical order, compile a list of product inventory 
levels from highest to lowest, or order rows by colors or icons. Sorting data helps you quickly 
visualize and understand your data better, organize and find the data that you want, and 
ultimately make more effective decisions. 

You can sort data by text (A to Z or Z to A), numbers (smallest to largest or largest to smallest), 
and dates and times (oldest to newest and newest to oldest) in one or more columns. You can 
also sort by a custom list (such as Large, Medium, and Small) or by format, including cell color, 
font color, or icon set. Most sort operations are column sorts, but you can also sort by rows. 

Sort criteria are saved with the workbook so that you can reapply the sort each time that you 
open the workbook for an Excel table, but not for a range of cells. If you want to save sort 
criteria so that you can periodically reapply a sort when you open a workbook, then it's a good 
idea to use a table. This is especially important for multicolumn sorts or for sorts that take a long 
time to create. 
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Custom Sort 
1. Select a range of cells with two or more columns of data, or make sure that the active 

cell is in a table with two or more columns.  
2. On the Home tab, in the Editing group, click Sort & Filter, and then click Custom Sort.  
3. The Sort dialog box is displayed.  
4. Under Column, in the Sort by box, select the first column that you want to sort.  
5. Under Sort On, select the type of sort. Do one of the following:  

• To sort by text, number, or date and time, select Values.  
• To sort by format, select Cell Color, Font Color, or Cell Icon. 

6. Under Order, select how you want to sort. Do one of the following:  
• For text values, select A to Z or Z to A.  
• For number values, select Smallest to Largest or Largest to Smallest.  
• For date or time values, select Oldest to Newest or Newest to Oldest.  
• To sort based on a custom list, select Custom List. 
• To add another column to sort by, click Add Level, and then repeat steps three 

through five.  
7. To copy a column to sort by, select the entry, and then click Copy Level.  
8. To delete a column to sort by, select the entry, and then click Delete Level.  

To change the order in which the columns are sorted, select an entry, and then click the Up or 
Down arrow to change the order.  Entries higher in the list are sorted before entries lower in the 
list. 

Filtering 
If your worksheet contains a lot of content, it can be difficult to find information quickly. Filters 
can be used to narrow down the data in your worksheet, allowing you to view only the 
information you need. 

Do one of the following:  

1. Select a range of cells containing alphanumeric data.  
2. On the Home tab, in the Editing group, click Sort & Filter, and then click Filter.  

The list of text values can be up to 10,000. If the list is large, clear (Select All) at the top, and 
then select the specific text values to filter by.  

Use the down arrow to the right of each column heading to display a unique list of items found in 
the column.  If you only want to see specific records (rows) of information you can unselect all 
items and select only the items you want to display. 

When a filter is applied to a column you will see the down arrow with a filter icon for that column. 

To remove a filter from a column, click on the down arrow for that column then click on. 
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Subtotal Function 
The Subtotal function returns a subtotal in a list or database. It is generally easier to create a list 
with subtotals by using the Subtotal command in the Outline group on the Data tab in the Excel 
desktop application. Once the subtotal list is created, you can modify it by editing the 
SUBTOTAL function. 

Syntax 

=SUBTOTAL(function_num,ref1,[ref2],...) 

The SUBTOTAL function syntax has the following arguments: 

Function_num     Required. The number 1-11 or 101-111 that specifies the function to use for 
the subtotal. 1-11 includes manually-hidden rows, while 101-111 excludes them; filtered-out 
cells are always excluded. 

PivotTables 
Create a PivotTable from a Local Data Source  
Local data is within the same Workbook and can be from any of the Worksheets. 

Make sure that the range has column headings or that headers are displayed in the 
table, and that there are no blank rows in the range or table. 
 

1. Make sure the active cell is part of the data range that you want in the 
PivotTable. 

2. On the Insert tab, in the Tables group, click PivotTable.  
3. In the Create PivotTable dialog box, make sure that Select a table or range is 

selected, and then in the Table/Range box, verify the range of cells. 
4. Excel automatically determines the range for the PivotTable report, but you can 

replace it by typing a different range or a name that you defined for the range.  
For data in another worksheet or workbook, include the workbook and worksheet 
name by using the following syntax [workbookname]sheetname!range. 

 
Do one of the following: 

• To place the PivotTable report in a new worksheet starting at cell A1, click New 
Worksheet. 

Function_num  
(includes hidden values)  

Function_num  
(ignores hidden values)  

Function  

1 101 AVERAGE 
2 102 COUNT 
3 103 COUNTA 
4 104 MAX 
5 105 MIN 
6 106 PRODUCT 
7 107 STDEV 
8 108 STDEVP 
9 109 SUM 
10 110 VAR 
11 111 VARP 
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• To place the PivotTable report at a specific location in an existing worksheet, 
select Existing Worksheet, and then in the Location box, specify the first cell in 
the range of cells where you want to position the PivotTable report. 

5. Click OK. 

PivotTable Fields Pane 

The windowpane that opens on the right side after you start a 
PivotTable can be used to select the fields you want to filter, 
add, rearrange the fields in the table and work with values. 

When you select a field from the field list, it will add it to one of 
the 4 areas. If it is a number field, it goes to the Values area, if it 
is text it goes to the Rows area. 

Add Fields to the PivotTable 

• To place a field in the default area of the layout 
section, select the check box next to the field name 
in the field section. 

• To place a field in a specific area of the layout 
section, right-click the field name in the field 
section, and then select Add to Report Filter, Add to 
Column Label, Add to Row Label, or Add to Values. 

• To drag a field to the area that you want, click and hold the field name in the field 
section, and then drag it to an area in the layout section. 

 
PivotTable Formula in Excel 
In Excel, once we create a pivot table, we can add formulas as calculated fields.  

To Create a PivotTable Formula 

1. First, create a pivot table with relevant fields we want to keep and then after selecting 
or putting the cursor on it,  

2. From Analyze tab on the ribbon, select Calculated Fields from the drop-down list of 
Fields, Items & Sets.  

3. There we will be able to see all the fields used in the pivot table along with the section 
Name and Formula section. Type a Name for the calculated field. 
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Filter PivotTable Data  
Filter your data to focus on a smaller portion of your PivotTable data for 
in-depth analysis.  

There are several ways to filter the data to only see the records of 
information you want. 

• From the Row Labels at the top of the PivotTable, click the down 
arrow. 

• From the Field List hesitate on the name of a field, click the 
down arrow. 

Filter with a Slicer 

First introduced in Excel 2010 as an interactive way to filter PivotTable 
data, slicers can now also filter data in Excel tables, query tables, and 
other data tables. Simpler to set up and use, slicers show the current filter, so you’ll know 
exactly what data you’re looking at. 

Slicers are easy-to-use filtering components that contain a set of buttons that enable you to 
quickly filter the data in a PivotTable report, without the need to open drop-down 
lists to find the items that you want to filter.  When you use a regular PivotTable 
report filter to filter on multiple items, the filter indicates only that multiple items are 
filtered, and you have to open a drop-down list to find the filtering details. However, 
a slicer clearly labels the filter that is applied and provides details so that you can easily 
understand the data that is displayed in the filtered PivotTable report. 

Add Slicers 
To add a Slicer to a Pivot Table: 

1. From the Filter Group on the Analyze tab of the Ribbon, click on the 
Insert Slicer Icon. 

2. Select the fields you want to filter by then click OK.  This will open a 
separate window for each field you choose. 

3. Click on entries from each of the Slicer windows to filter by that item.  
Use the CTRL key to select multiple items.  

Filter with Timeline 

Instead of adjusting filters to show dates, you can use a PivotTable Timeline—a dynamic filter 
option that lets you easily filter by date/time and zoom in on the period you want with a slider 
control. 
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Much like a slicer for filtering data, you can insert a Timeline one time, and then keep it with 
your PivotTable to change the range of time whenever you like. 

1. Click anywhere in a PivotTable to show the 
PivotTable Tools ribbon group,  

2. Click the Analyze tab then Insert Timeline. 
3. Choose one or more “date” fields from the list then 

click OK. 

With your Timeline in place, you’re ready to filter by a time period in one of four-time levels 
(years, quarters, months, or days). 

Drag the Timeline scroll bar to the time period you want to analyze. 

Visualizing Data with Charts  

Create Charts  
To create a professional-looking chart that displays the details that you want, you can 
modify the chart, apply predefined styles and layouts, and add eye-catching formatting. 
You can also reuse a favorite chart by saving it as a chart template. 
 
To create a Chart: 

1. Select your data 
2. Go to the Insert Tab and choose one of the Chart 

Types in the Chart Group. 
3. Once your chart has been created you now can use the contextual tools for 

formatting the chart. 
 

Recommended Charts 

With Chart recommendations, Excel recommends the most suitable charts 
for your data. Get a quick peek to see how your data looks in the different 
charts, and then simply pick the one that shows the insights you want to 
present.  

The Recommended Charts button on the Insert tab lets you pick from a 
variety of charts that are right for your data. Related types of charts like 
scatter and bubble charts are under one umbrella. When you click a chart, you’ll also see a 
simpler Chart Tools ribbon. With just a Design and Format tab, it should be easier to find what 
you need. 
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Modify and Format Charts  

Add Chart Elements 

Three chart buttons let you quickly pick and preview changes to chart elements (like titles or 
labels), the look and style of your chart, or to the data that is shown.  

Layout Options 

On the Layout tab for Chart options, you will find ways to add or remove different 
elements of a Chart like: 

• Titles – Chart and Axis 
• Legends 
• Data Labels 
• Data Tables 

Combine Data from Multiple Sources 
Link Data 
In Excel, a link is a formula that dynamically pulls in data from a cell in another worksheet. The 
worksheet can be in the same workbook or a different workbook. The destination worksheet is 
the worksheet that contains the link formula. The worksheet containing the data that will be 
brought in is called the source worksheet. 

1. Click in a cell where you want to linked data to appear. 
2. Type =CellReference like =C4. Whatever is in cell C4 will appear on the cell you linked 

it to. 

Copy Paste Link 

Although you can copy and paste data from one Excel file to another, you can also create a link 
between two files or workbooks. When you create a link between files, the copied data updates 
when the original data changes. It's also possible to create a link between a chart located in an 
Excel workbook and a Microsoft Word file or PowerPoint slide.  

1. Select the cell(s) you want to link then copy. 
2. Navigate to where you want to link them, right click on the cell. 
3. Left-click on Paste Link from the pop-up menu. 

Consolidate Data 
To summarize and report results from separate worksheets, you can consolidate data from each 
sheet into a master worksheet. The sheets can be in the same workbook as the master worksheet, or 
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in other workbooks. When you consolidate data, you assemble data so that you can more easily 
update and aggregate as necessary. 

1. Open all files (workbooks) that contain the data you want to consolidate. 
2. Ensure the data is organized in the same way. 
3. On the Data ribbons select Data 

Tools and then Consolidate. 
4. Select the method of consolidation 

(in our example, it’s Sum). 
5. Select the data including the labels 

and click Add. 
6. Repeat step 5 for each worksheet or 

workbook that contains the data.  
7. Check boxes “top row”, “left column”, 

and “create links to data source” 
(note you don’t have to tick these 
boxes if you don’t want labels or 
don’t want live links) and click the OK button. 

Hyperlinks 
For quick access to related information in another file or on a web page, you can insert a 
hyperlink in a worksheet cell. 

1. On a worksheet, click the cell where you want to create a hyperlink. You can also 
select an object, such as a picture or an element in a chart, that you want to use to 
represent the hyperlink. 

2. On the Insert tab, in the Links group, click Hyperlink . 
3. You can also right-click the cell or graphic and then click Hyperlink on the shortcut 

menu, or you can press Ctrl+K. 
4. Under Link to, click Create New Document. 
5. In the Name of new document box, type a name for the new file. 

Tip: To specify a location other than the one shown under Full path, you can type the new 
location preceding the name in the Name of new document box, or you can click Change to 
select the location that you want and then click OK. 

6. Under When to edit, click Edit the new document later or Edit the new document now 
to specify when you want to open the new file for editing. 

7. In the Text to display box, type the text that you want to use to represent the hyperlink. 
8. To display helpful information when you rest the pointer on the hyperlink, click 

ScreenTip, type the text that you want in the ScreenTip text box, and then click OK. 
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